#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](?:.{1}[0-9])?)?"?$"
Local $sString = "180° 1' 3"" & @CRLF & _
"// Stop at 360°" & @CRLF & _
"360° 1' 2" " & @CRLF & _
"-360° 1' 2"" & @CRLF & _
"259° 59' 59.9"" & @CRLF & _
"// Can't accept 2 digit precision decimal seconds." & @CRLF & _
"259° 59' 59.99" " & @CRLF & _
"// Negative angle" & @CRLF & _
"-45° 1' 2"" & @CRLF & _
"// A little bit weird" & @CRLF & _
"00° 1' 2"" & @CRLF & _
"00° 00' 00.0"" & @CRLF & _
"// Whops! Something wrong here." & @CRLF & _
"1° 2' 599"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")