using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](?:.{1}[0-9])?)?""?$";
string input = @"180° 1' 3""
// Stop at 360°
360° 1' 2""
-360° 1' 2""
259° 59' 59.9""
// Can't accept 2 digit precision decimal seconds.
259° 59' 59.99""
// Negative angle
-45° 1' 2""
// A little bit weird
00° 1' 2""
00° 00' 00.0""
// Whops! Something wrong here.
1° 2' 599""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}