import re
regex = re.compile(r"^(?:(-?360(*ACCEPT))|(-?[1-3]?[0-9]?[0-9]?))°?\s?([0-5]?[0-9])?\'?\s?([0-5]?[0-9](?:.{1}[0-9])?)?\"?$", flags=re.MULTILINE)
test_str = ("180° 1' 3\"\n"
"// Stop at 360°\n"
"360° 1' 2\" \n"
"-360° 1' 2\"\n"
"259° 59' 59.9\"\n"
"// Can't accept 2 digit precision decimal seconds.\n"
"259° 59' 59.99\" \n"
"// Negative angle\n"
"-45° 1' 2\"\n"
"// A little bit weird\n"
"00° 1' 2\"\n"
"00° 00' 00.0\"\n"
"// Whops! Something wrong here.\n"
"1° 2' 599\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")