#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([1-9]\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\d|3[0-1])T([0-4]\d|5[0-9]):([0-4]\d|5[0-9]):([0-4]\d|5[0-9])(\.\d{3})?Z$"
Local $sString = "2019-01-01T00:00:00Z" & @CRLF & _
"1000-01-01T00:00:00.000Z" & @CRLF & _
"2019-12-31T59:59:59.999Z" & @CRLF & _
"2019-13-32T60:60:60Z" & @CRLF & _
"2019-00-00T00:00:00Z" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")