const regex = /^([1-9]\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\d|3[0-1])T([0-4]\d|5[0-9]):([0-4]\d|5[0-9]):([0-4]\d|5[0-9])(\.\d{3})?Z$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([1-9]\\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\\d|3[0-1])T([0-4]\\d|5[0-9]):([0-4]\\d|5[0-9]):([0-4]\\d|5[0-9])(\\.\\d{3})?Z$', 'gm')
const str = `2019-01-01T00:00:00Z
1000-01-01T00:00:00.000Z
2019-12-31T59:59:59.999Z
2019-13-32T60:60:60Z
2019-00-00T00:00:00Z
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}