import re
regex = re.compile(r"^([1-9]\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\d|3[0-1])T([0-4]\d|5[0-9]):([0-4]\d|5[0-9]):([0-4]\d|5[0-9])(\.\d{3})?Z$", flags=re.MULTILINE)
test_str = ("2019-01-01T00:00:00Z\n"
"1000-01-01T00:00:00.000Z\n"
"2019-12-31T59:59:59.999Z\n"
"2019-13-32T60:60:60Z\n"
"2019-00-00T00:00:00Z\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")