import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([1-9]\\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\\d|3[0-1])T([0-4]\\d|5[0-9]):([0-4]\\d|5[0-9]):([0-4]\\d|5[0-9])(\\.\\d{3})?Z$";
final String string = "2019-01-01T00:00:00Z\n"
+ "1000-01-01T00:00:00.000Z\n"
+ "2019-12-31T59:59:59.999Z\n"
+ "2019-13-32T60:60:60Z\n"
+ "2019-00-00T00:00:00Z\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}