using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([1-9]\d{3})-(0[1-9]|1[0-2])-(0[1-9]|[1-2]\d|3[0-1])T([0-4]\d|5[0-9]):([0-4]\d|5[0-9]):([0-4]\d|5[0-9])(\.\d{3})?Z$";
string input = @"2019-01-01T00:00:00Z
1000-01-01T00:00:00.000Z
2019-12-31T59:59:59.999Z
2019-13-32T60:60:60Z
2019-00-00T00:00:00Z
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}