# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(AVE)\s+(?=\d+\b)/$1 \/ /gm;t' <<< "10 AVE 2 ST
NORTH 100 AVE 5 TERR
S 39 AVE NW
S 39 AVE 1R
S 39 AVE 234 S"