#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(AVE)\s+(?=\d+\b)"
Local $sString = "10 AVE 2 ST" & @CRLF & _
"NORTH 100 AVE 5 TERR" & @CRLF & _
"S 39 AVE NW" & @CRLF & _
"S 39 AVE 1R" & @CRLF & _
"S 39 AVE 234 S"
Local $sSubst = "$1 / "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)