re = /(AVE)\s+(?=\d+\b)/m
str = '10 AVE 2 ST
NORTH 100 AVE 5 TERR
S 39 AVE NW
S 39 AVE 1R
S 39 AVE 234 S'
subst = '$1 / '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result