use strict;
my $str = '10 AVE 2 ST
NORTH 100 AVE 5 TERR
S 39 AVE NW
S 39 AVE 1R
S 39 AVE 234 S';
my $regex = qr/(AVE)\s+(?=\d+\b)/mp;
my $subst = '$1 / ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";