using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(AVE)\s+(?=\d+\b)";
string substitution = @"$1 / ";
string input = @"10 AVE 2 ST
NORTH 100 AVE 5 TERR
S 39 AVE NW
S 39 AVE 1R
S 39 AVE 234 S";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}