$re = '/(AVE)\s+(?=\d+\b)/m';
$str = '10 AVE 2 ST
NORTH 100 AVE 5 TERR
S 39 AVE NW
S 39 AVE 1R
S 39 AVE 234 S';
$subst = "$1 / ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;