#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)This is a .* according to .* .*"
Local $sString = "This is a xobject according to ynation ypeople" & @CRLF & _
"This was a xobject according to ynation" & @CRLF & _
"This is a yobject according to znation ypeople" & @CRLF & _
"This is a bobject according cnatione" & @CRLF & _
"This is a cobject according to hpeople" & @CRLF & _
"This is a aobject according to bnation ypeople" & @CRLF & _
"This is an aobject according to bnation ypeople" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")