using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"This is a .* according to .* .*";
string input = @"This is a xobject according to ynation ypeople
This was a xobject according to ynation
This is a yobject according to znation ypeople
This is a bobject according cnatione
This is a cobject according to hpeople
This is a aobject according to bnation ypeople
This is an aobject according to bnation ypeople
";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}