$re = '/This is a .* according to .* .*/i';
$str = 'This is a xobject according to ynation ypeople
This was a xobject according to ynation
This is a yobject according to znation ypeople
This is a bobject according cnatione
This is a cobject according to hpeople
This is a aobject according to bnation ypeople
This is an aobject according to bnation ypeople
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);