const regex = /This is a .* according to .* .*/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('This is a .* according to .* .*', 'ig')
const str = `This is a xobject according to ynation ypeople
This was a xobject according to ynation
This is a yobject according to znation ypeople
This is a bobject according cnatione
This is a cobject according to hpeople
This is a aobject according to bnation ypeople
This is an aobject according to bnation ypeople
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}