import re
regex = re.compile(r"This is a .* according to .* .*", flags=re.IGNORECASE)
test_str = ("This is a xobject according to ynation ypeople\n"
"This was a xobject according to ynation\n"
"This is a yobject according to znation ypeople\n"
"This is a bobject according cnatione\n"
"This is a cobject according to hpeople\n"
"This is a aobject according to bnation ypeople\n"
"This is an aobject according to bnation ypeople\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")