use strict;
my $str = 'This is a xobject according to ynation ypeople
This was a xobject according to ynation
This is a yobject according to znation ypeople
This is a bobject according cnatione
This is a cobject according to hpeople
This is a aobject according to bnation ypeople
This is an aobject according to bnation ypeople
';
my $regex = qr/This is a .* according to .* .*/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}