using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^\_]*\_){3}([^_]*)([^.*]*)$";
string substitution = @"$1";
string input = @"Br_LV_0040324_BC1_1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}