re = /(?:[^\_]*\_){3}([^_]*)([^.*]*)$/m
str = 'Br_LV_0040324_BC1_1'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result