import re
regex = re.compile(r"(?:[^\_]*\_){3}([^_]*)([^.*]*)$", flags=re.MULTILINE)
test_str = "Br_LV_0040324_BC1_1"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)