use strict;
my $str = 'Br_LV_0040324_BC1_1';
my $regex = qr/(?:[^\_]*\_){3}([^_]*)([^.*]*)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";