#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)product_attribute_2[\s\S]*"(\d+)"[\s\S]*select>"
Local $sString = "<select id="product_attribute_1">" & @CRLF & _
" <option value="1">2.2 GHz</option>" & @CRLF & _
" <option selected="selected" value="2">2.5 GHz</option>" & @CRLF & _
"</select>" & @CRLF & _
"<select id="product_attribute_2">" & @CRLF & _
" <option value="3">2GB</option>" & @CRLF & _
" <option value="4">4GB</option>" & @CRLF & _
" <option value="5">8GB</option>" & @CRLF & _
"</select>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")