// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)product_attribute_2[\s\S]*"(\d+)"[\s\S]*select>"#).unwrap();
let string = "<select id=\"product_attribute_1\">
<option value=\"1\">2.2 GHz</option>
<option selected=\"selected\" value=\"2\">2.5 GHz</option>
</select>
<select id=\"product_attribute_2\">
<option value=\"3\">2GB</option>
<option value=\"4\">4GB</option>
<option value=\"5\">8GB</option>
</select>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}