re = /product_attribute_2[\s\S]*"(\d+)"[\s\S]*select>/m
str = '<select id="product_attribute_1">
<option value="1">2.2 GHz</option>
<option selected="selected" value="2">2.5 GHz</option>
</select>
<select id="product_attribute_2">
<option value="3">2GB</option>
<option value="4">4GB</option>
<option value="5">8GB</option>
</select>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end