# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"product_attribute_2[\s\S]*\"(\d+)\"[\s\S]*select>"
test_str = ("<select id=\"product_attribute_1\">\n"
" <option value=\"1\">2.2 GHz</option>\n"
" <option selected=\"selected\" value=\"2\">2.5 GHz</option>\n"
"</select>\n"
"<select id=\"product_attribute_2\">\n"
" <option value=\"3\">2GB</option>\n"
" <option value=\"4\">4GB</option>\n"
" <option value=\"5\">8GB</option>\n"
"</select>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.