using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"product_attribute_2[\s\S]*""(\d+)""[\s\S]*select>";
string input = @"<select id=""product_attribute_1"">
<option value=""1"">2.2 GHz</option>
<option selected=""selected"" value=""2"">2.5 GHz</option>
</select>
<select id=""product_attribute_2"">
<option value=""3"">2GB</option>
<option value=""4"">4GB</option>
<option value=""5"">8GB</option>
</select>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}