const regex = /product_attribute_2[\s\S]*"(\d+)"[\s\S]*select>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('product_attribute_2[\\s\\S]*"(\\d+)"[\\s\\S]*select>', 'gm')
const str = `<select id="product_attribute_1">
<option value="1">2.2 GHz</option>
<option selected="selected" value="2">2.5 GHz</option>
</select>
<select id="product_attribute_2">
<option value="3">2GB</option>
<option value="4">4GB</option>
<option value="5">8GB</option>
</select>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}