# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/t//gm;t' <<< "12345
123456789
123456.1234"