const regex = /t/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('t', 'gm')
const str = `12345
123456789
123456.1234`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);