$re = '/t/m';
$str = '12345
123456789
123456.1234';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;