use strict;
my $str = '12345
123456789
123456.1234';
my $regex = qr/t/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";