# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\w)ed\b//gm;t' <<< "I have worked a lot and ruined my health but I have loved my job even if I habe been manipulated and ruined by this Photoshopped picture. Ed and Eddy are happy today even if they have partied the whole night. "