re = /(?<=\w)ed\b/m
str = 'I have worked a lot and ruined my health but I have loved my job even if I habe been manipulated and ruined by this Photoshopped picture. Ed and Eddy are happy today even if they have partied the whole night. '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result