const regex = /(?<=\w)ed\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\w)ed\\b', 'gm')
const str = `I have worked a lot and ruined my health but I have loved my job even if I habe been manipulated and ruined by this Photoshopped picture. Ed and Eddy are happy today even if they have partied the whole night. `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);