use strict;
my $str = 'I have worked a lot and ruined my health but I have loved my job even if I habe been manipulated and ruined by this Photoshopped picture. Ed and Eddy are happy today even if they have partied the whole night. ';
my $regex = qr/(?<=\w)ed\b/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";