#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\w)ed\b"
Local $sString = "I have worked a lot and ruined my health but I have loved my job even if I habe been manipulated and ruined by this Photoshopped picture. Ed and Eddy are happy today even if they have partied the whole night. "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)