import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\w)ed\\b";
final String string = "I have worked a lot and ruined my health but I have loved my job even if I habe been manipulated and ruined by this Photoshopped picture. Ed and Eddy are happy today even if they have partied the whole night. ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}