# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[|\]|,)//gm;t' <<< "[33.864423279999997, -84.184913890000004]"