import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<[^<>]+>";
final String string = "Andre Luis <andre.luis@sulamerica.com.br>\n"
+ "Andrea Bertolozo <andrea.bertolozo@sulamerica.com.br>\n"
+ "Carlos Miranda <carlos.miranda@sulamerica.com.br>\n"
+ "Marcia Pereira <marcia.pereira@sulamerica.com.br>\n"
+ "Namaste Menegassi Iazykoff <namaste@ciandt.com.br>\n"
+ "Rafael Pedroso Moraes <rafael.pedroso.moraes@everis.com>\n"
+ "Rivaldo Viscardi <rivaldo.viscardi@sulamerica.com.br>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}