const regex = /<[^<>]+>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^<>]+>', 'g')
const str = `Andre Luis <andre.luis@sulamerica.com.br>
Andrea Bertolozo <andrea.bertolozo@sulamerica.com.br>
Carlos Miranda <carlos.miranda@sulamerica.com.br>
Marcia Pereira <marcia.pereira@sulamerica.com.br>
Namaste Menegassi Iazykoff <namaste@ciandt.com.br>
Rafael Pedroso Moraes <rafael.pedroso.moraes@everis.com>
Rivaldo Viscardi <rivaldo.viscardi@sulamerica.com.br>`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);