import re
regex = re.compile(r"<[^<>]+>")
test_str = ("Andre Luis <andre.luis@sulamerica.com.br>\n"
"Andrea Bertolozo <andrea.bertolozo@sulamerica.com.br>\n"
"Carlos Miranda <carlos.miranda@sulamerica.com.br>\n"
"Marcia Pereira <marcia.pereira@sulamerica.com.br>\n"
"Namaste Menegassi Iazykoff <namaste@ciandt.com.br>\n"
"Rafael Pedroso Moraes <rafael.pedroso.moraes@everis.com>\n"
"Rivaldo Viscardi <rivaldo.viscardi@sulamerica.com.br>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)