# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/@[[]member=(?:"|)(.*?)(?:"|)[]]/@\1/gmi;t' <<< "@[member=one.rrrr]
@[member=\"one\"] @[member=\"two\"]
@[member=\"one\"]@[member=\"two\"]
@[member=\"one\"]
@[member=name] and @[member=\"name_virgolette\"]"