package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)@[[]member=(?:"|)(.*?)(?:"|)[]]`)
var str = `@[member=one.rrrr]
@[member="one"] @[member="two"]
@[member="one"]@[member="two"]
@[member="one"]
@[member=name] and @[member="name_virgolette"]`
var substitution = "@\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}