using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"@[[]member=(?:""|)(.*?)(?:""|)[]]";
string substitution = @"@\1";
string input = @"@[member=one.rrrr]
@[member=""one""] @[member=""two""]
@[member=""one""]@[member=""two""]
@[member=""one""]
@[member=name] and @[member=""name_virgolette""]";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}