$re = '/@[[]member=(?:"|)(.*?)(?:"|)[]]/mi';
$str = '@[member=one.rrrr]
@[member="one"] @[member="two"]
@[member="one"]@[member="two"]
@[member="one"]
@[member=name] and @[member="name_virgolette"]';
$subst = "@\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;