use strict;
my $str = '@[member=one.rrrr]
@[member="one"] @[member="two"]
@[member="one"]@[member="two"]
@[member="one"]
@[member=name] and @[member="name_virgolette"]';
my $regex = qr/@[[]member=(?:"|)(.*?)(?:"|)[]]/mip;
my $subst = '@\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";