import Foundation
let pattern = #"@[[]member=(?:"|)(.*?)(?:"|)[]]"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
@[member=one.rrrr]
@[member="one"] @[member="two"]
@[member="one"]@[member="two"]
@[member="one"]
@[member=name] and @[member="name_virgolette"]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"@\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)